我们很高兴地宣布推出 React 开发者工具的新版本,现在可以在 Chrome,Firefox和(Chromium)Edge 中使用!

有什么变化?

第 4 版中发生了很多变化!从较高的层面来看,这个新版本应该可以提供显着的性能提升和改进的导航体验。它还提供对 React Hooks 的完全支持,包括检查嵌套对象。

DevTools第4版截图

访问互动教程试用新版本或参见更改日志中的相关演示视频和更多详细信息。

支持哪些版本的 React?

react-dom

  • 0-14.x: 不支持
  • 15.x: 支持(新组件过滤器功能除外)
  • 16.x: 支持

react-native

  • 0-0.61: 不支持
  • 0.62: 将要支持(当0.62发布时)

如何获得新的 DevTools?

React DevTools 可作为 ChromeFirefox 的扩展程序提供。如果你已经安装了扩展程序,则会在接下来的几个小时内自动更新。

如果你使用独立 shell(例如在 React Native 或 Safari 中),则可以从 NPM 安装新版本:

npm install -g react-devtools@^4

所有DOM元素都去了哪里?

新的 DevTools 提供了一种从树中过滤组件的方法,以便更轻松地导航嵌套的层次结构。主节点(例如HTML <div>,React Native <View>)默认是隐藏的,但可以禁用此过滤器:

DevTools组件过滤器

如何获取旧版本?

如果你使用的是 React Native 60 版本(或更早版本),则可以从 NPM 安装以前版本的 DevTools:

npm install --dev react-devtools@^3

对于旧版本的 React DOM(v 0.14 或更早版本),你需要从源代码构建扩展:

# Checkout the extension source
git clone https://github.com/facebook/react-devtools

cd react-devtools

# Install dependencies and build the unpacked extension
yarn install
yarn build:extension

# Follow the on-screen instructions to complete installation

谢谢!

我们要感谢所有测试 DevTools v 4 早期版本的人。你的反馈有助于显着改进此初始版本。

我们仍然计划开发许多令人兴奋的功能,欢迎提供反馈!请打开 GitHub issue 或关注 Twitter 上的 @reactjs